This repository has been archived on 2023-07-17. You can view files and clone it, but cannot push or open issues or pull requests.
clan-docs/example-flake-boilerplate.nix
2023-06-25 13:15:18 +02:00

16 lines
447 B
Nix

{
inputs.nixpkgs.url = github:NixOS/nixpkgs/nixos-unstable;
inputs.hiboss.url = "git+https://git.hiboss.com/hiboss";
inputs.hiboss.nixpkgs.follows = "nixpkgs";
outputs = { self, nixpkgs, hiboss, ... }:
let
system = "x86_64-linux";
pkgs = import nixpkgs { inherit system; };
hiboss = import hiboss { inherit system pkgs; };
in
{
nixosConfigurations = builtins.fromJSON (import ./configs.json);
};
}