clan-core/nixosModules/clanCore/schema.nix
DavHau 3771be2110
All checks were successful
checks / check-links (pull_request) Successful in 15s
checks / checks-impure (pull_request) Successful in 1m52s
checks / checks (pull_request) Successful in 3m32s
checks: add check for rendering docs
2024-03-27 16:59:42 +07:00

13 lines
367 B
Nix

{ options, lib, ... }:
let
jsonschema = import ../../lib/jsonschema { inherit lib; };
in
{
options.clanSchema = lib.mkOption {
type = lib.types.attrs;
description = "The json schema for the .clan options namespace";
default = jsonschema.parseOptions options.clan;
defaultText = lib.literalExpression "jsonschema.schemaToJSON options.clan";
};
}